Driver ATI en Debian Sid con X.Org 7.0

Repositorio utilizado:
deb http://mirrors.kernel.org/debian/ unstable main contrib non-free
deb-src http://mirrors.kernel.org/debian/ unstable main contrib non-free

Instalar los siguientes paquetes:

module-assistant
build-essential
fakeroot
dh-make
debconf
libstdc++5
linux-headers-$(uname -r)
fglrx-control – Control panel for the ATI graphics accelerators
fglrx-driver – Display driver for the ATI graphics accelerators
fglrx-driver-dev – Display driver for the ATI graphics accelerators (development files)
fglrx-kernel-src – Kernel module source for the ATI graphics accelerators

Luego de haber instalado esos paquetes:

$ module-assistant a-i fglrx
$ aticonfig –initial
$ fgl_glxgears

Aqui posteo mi info:

[22:15:56][ROOT@debian /home/alberk]$: fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON 9550 Generic
OpenGL version string: 2.0.5755 (8.24.8)

[22:16:01][ROOT@debian /home/alberk]$: fgl_glxgears
Using GLX_SGIX_pbuffer
1837 frames in 5.0 seconds = 367.400 FPS
1929 frames in 5.0 seconds = 385.800 FPS
1929 frames in 5.0 seconds = 385.800 FPS
1919 frames in 5.0 seconds = 383.800 FPS
1926 frames in 5.0 seconds = 385.200 FPS
1908 frames in 5.0 seconds = 381.600 FPS

2 comentarios sobre “Driver ATI en Debian Sid con X.Org 7.0”

  1. Muchas gracias por el pequeño atajo que supone no tener que estar 10 horas más intentando hacer funcionar los dichosos drivers!! 😉

    La verdad es que soy bastante novato en linux e intento hacer todo manual para cogerle el truco, pero entre la migracion a xorg 7.0 un rato con los paquetes de la pagina de ati, andaba ya un poco liado.

    Lo que no he terminado de entender es el proceso que has puesto: sino entiendo mal mediante module-assistant se ha autocompilado e instalado los modulos del driver?

    De nuevo muchas gracias, adoro linux, y mas debian, pero a veces como no seas “un poco” mañoso resulta demasiado oscuro y complicado todo.

  2. Muchas gracias tio, no conocía esos repositorios, siempre he isntalado los dirver directamente con el script de la página oficial de ATi en Ubuntu (8.10, 9.04 y 9.10), pero ahora me instale Sidux 2009-04 y no era capaz de instalar correctamente el driver… y los drivers de este repositorio funcionan perfectamente en Sidux 2009-04 (basado en Debian Sid)…

    Si no te importa, voy a hacer una copia en mi blog y a poner un link a tu blog.

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos necesarios están marcados *